Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Which PHP version as minimum for webERP?
03-28-2014, 12:27 AM, (This post was last modified: 03-28-2014, 12:47 AM by icedlava.)
Which PHP version as minimum for webERP?
Opening this thread in case for discussion of minimum recommended version for webERP. Rather than hijacking other threads, the topic could be better dealt with here.

At the moment the minimum recommended PHP for webERP is 5.2.

I'd like to suggest we consider upgrading the minimum recommended php for webERP to 5.3 (or even php 5.2.6 ?? or higher). Note this is a --recommended-- php version.

I would support a maintenance version of php 5.2 webERP branch. A development branch with a minimum recommended php of 5.3.

Here are a few reasons that you may or may not think are important.

1. PHP 5.2 is no longer supported and does not get security patches. End of life was some years ago. As a community we should encourage users to upgrade their PHP for their benefit and webERP community. It doesn't look good for webERP if someone has a hacked installation even if it is not directly webERP responsible.

2. If we support php 5.2 we cannot take advantage of other features of php 5.3 without also writing additional code that supports the php 5.2 - sometimes that is just not practical and we have to forgo the higher php code which cold be more efficient, as an example.

3. As an open source community, we should encourage upgrading of our code to a minimum recommended php 5.3 and in so doing encourages others. An app that does not support higher php can hold up an upgrade of a whole server. This can create headaches when one app requires an outdated php 5.2, and another has a minimum of eg php 5.3 to run, not to mention putting the whole server at risk with unsupported php and potential security issues.


I quote from another thread:
Quote:I hear WordPress still has 5.3 issues in their code.

And it will continue to probably until they fix php 5.3 as their minimum recommended version. It's a problem that will go round and round.

Wordpress has a huge user base and probably many from years ago, that installed their sites on old php 5.2 servers. It has a huge following with many new users over the last few years - all on servers with a minimum of php 5.3 (it's offered as standard on most major hosting companies )

Now, even if Wordpress wanted to - how can they drop support for php 5.2 overnight?

The problem is that such a huge community has huge number of developers of many different standards and many would have long forgotten php 5.2 (end of life some years ago) and moved to a minimum of php 5.3 to take advantage of the many, many improvements in security, especially performance, error handling and so on.

This will create an issue for wordpress if their core code doesn't support php 5.3 fully. Plugins may not work, php libraries require php 5.3 but some old wordpress plugins are written for php 5.2 and so on.

Thus, I would expect wordpress to have lots of issues both directly and indirectly with anything written in php 5.3 until they make it their minimum. If wordpress updated then a whole lot of CMS users could also probably update their servers and move to php 5.3 rather than keeping them on an old insecure server.

Now, with some hosting companies offering php 5.4 as standard, the issue can only get worse.


Messages In This Thread
Which PHP version as minimum for webERP? - by icedlava - 03-28-2014, 12:27 AM

Forum Jump:

Users browsing this thread: 1 Guest(s)