Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Supplier credit note not working
04-27-2021, 11:46 PM,
#1
Supplier credit note not working
webERP 4.15.1
In "Supplier credit note" there is an option to credit against "Purchase Order" , SuppCreditGRNs.php
In this screen, there is a list of GRN to credit. When "Add to Credit Note" is pressed nothing happen, just a title screen from SuppCreditGRNs.php file.
Is there any option in "System Parameters" that control this, or ...?
Thank you
Srdjan
Reply
04-28-2021, 01:24 PM,
#2
RE: Supplier credit note not working
I'll have to check, but is there any error in your server error log?
Reply
04-28-2021, 06:58 PM,
#3
RE: Supplier credit note not working
(04-27-2021, 11:46 PM)srdjanm Wrote: webERP 4.15.1
In "Supplier credit note" there is an option to credit against "Purchase Order" , SuppCreditGRNs.php
In this screen, there is a list of GRN to credit. When "Add to Credit Note" is pressed nothing happen, just a title screen from SuppCreditGRNs.php file.
Is there any option in "System Parameters" that control this, or ...?
Thank you
Srdjan
Did you add in the quantity to be credited (see screenshot below)? It defaults to zero (do people think this is correct?) and if no quantity is entered nothing happens.

Tim

   
Reply
04-29-2021, 03:51 AM,
#4
RE: Supplier credit note not working
(04-28-2021, 01:24 PM)TurboPT Wrote: I'll have to check, but is there any error in your server error log?
I tested on my local server, same problem and there is an error:
[Wed Apr 28 13:44:13.945317 2021] [php7:error] [pid 1579] [client 127.0.0.1:40576] PHP Fatal error:  Uncaught ArgumentCountError: Too few arguments to function SuppTrans::Add_GRN_To_Trans(), 19 passed in /var/www/html/webERP-4.15.1/SuppCreditGRNs.php on line 72 and exactly 20 expected in /var/www/html/webERP-4.15.1/includes/DefineSuppTransClass.php:88\nStack trace:\n#0 /var/www/html/webERP-4.15.1/SuppCreditGRNs.php(72): SuppTrans->Add_GRN_To_Trans('2237', '2402', 'BLACK-SPR-OR', 'Black Spruce Oi...', '18', '18', '18.00', '136', '136.00', false, '130', '0', '0', '1420', '1503', '0', 0, '2', '1472')\n#1 {main}\n  thrown in /var/www/html/webERP-4.15.1/includes/DefineSuppTransClass.php on line 88, referer: http://localhost/webERP-4.15.1/SuppCreditGRNs.php
Reply
04-29-2021, 03:53 AM,
#5
RE: Supplier credit note not working
(04-28-2021, 06:58 PM)falkoner Wrote:
(04-27-2021, 11:46 PM)srdjanm Wrote: webERP 4.15.1
In "Supplier credit note" there is an option to credit against "Purchase Order" , SuppCreditGRNs.php
In this screen, there is a list of GRN to credit. When "Add to Credit Note" is pressed nothing happen, just a title screen from SuppCreditGRNs.php file.
Is there any option in "System Parameters" that control this, or ...?
Thank you
Srdjan
Did you add in the quantity to be credited (see screenshot below)? It defaults to zero (do people think this is correct?) and if no quantity is entered nothing happens.

Tim

Yes, I added the quantity to credit, Same problem in two different environment, On my local, test server and on production, hosting environment
Thank you
Srdjan
Reply
04-29-2021, 01:00 PM, (This post was last modified: 05-02-2021, 07:44 AM by TurboPT.)
#6
RE: Supplier credit note not working
Thanks for the error info @srdjanm, I see that there is one parameter short, looking into what should be supplied for the value for that area.
Reply
05-02-2021, 07:09 AM, (This post was last modified: 05-02-2021, 07:45 AM by TurboPT.)
#7
RE: Supplier credit note not working
In file SuppCreditGRNs.php on line 72:

Change:
PHP Code:
$_POST['GRNBatchNo']); 

To:
PHP Code:
$_POST['GRNBatchNo'],
$_SESSION['SuppTrans']->SupplierID); 

To use the SupplierID as the last parameter.
Reply
05-03-2021, 11:54 PM,
#8
RE: Supplier credit note not working
Paul, have you committed this fix?

Tim
Reply
05-04-2021, 11:18 AM, (This post was last modified: 05-04-2021, 10:02 PM by TurboPT.)
#9
RE: Supplier credit note not working
Tim, not yet, I was hoping to get some feedback first, but I'll do so tomorrow either way.

I decided to go ahead and commit, but it looks like the exact same change that I posted has already been applied? (glad to see that I had the same idea)
See this commit.
Reply
05-04-2021, 10:04 PM,
#10
RE: Supplier credit note not working
Thanks Paul I hadn't checked to see if it was already committed

Tim
Reply


Forum Jump:


Users browsing this thread: 2 Guest(s)