Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PO receive error
03-07-2020, 04:35 PM
Post: #1
PO receive error
Good day
Having trouble receiving an item on a PO. Other items received OK.

Database Error 1366 : CRITICAL ERROR! NOTE DOWN THIS ERROR AND SEEK ASSISTANCE: A GRN record could not be inserted. This receipt of goods has not been processed because
Incorrect double value: '' for column `weberp`.`grns`.`stdcostunit` at row 1

√óDatabase SQL Failure : The following SQL to insert the GRN record was used
INSERT INTO grns (grnbatch, podetailitem, itemcode, itemdescription, deliverydate, qtyrecd, supplierid, stdcostunit, supplierref) VALUES ('172', '596', 'SOCSIL6W', '3 WAY SOCKET / FEMALE HEADER / 2.54 PITCH, HEIGHT=', '2020-03-07', '100', 'MAN001', '', '')

√óDatabase Rollback Due to Error Above : Rolling Back Transaction OK
Back to Purchase Orders

Receive Purchase Order : 141 from Mantech Electronics
Find all posts by this user
Quote this message in a reply
03-07-2020, 05:44 PM
Post: #2
RE: PO receive error
Hi Alan, does this part have a cost set up for it?

Tim
Visit this user's website Find all posts by this user
Quote this message in a reply
03-07-2020, 11:47 PM
Post: #3
RE: PO receive error
Hi Tim,
yes it does.
Find all posts by this user
Quote this message in a reply
03-07-2020, 11:57 PM
Post: #4
RE: PO receive error
Hmmmm, interesting. The error message is saying that the standard cost field is blank, not zero but blank. This field is saved at the point the purchase order is raised.
Can you run the following database query:

SELECT stdcostunit FROM purchorderdetails WHERE podetailitem=596;

and let me know the result.
Tim
Visit this user's website Find all posts by this user
Quote this message in a reply
03-08-2020, 12:13 AM
Post: #5
RE: PO receive error
localhost/weberp/purchorderdetails/ http://localhost/phpmyadmin/tbl_sql.php?db=weberp&table=purchorderdetails
Showing rows 0 - 0 (1 total, Query took 0.0011 seconds.)

SELECT stdcostunit FROM purchorderdetails WHERE podetailitem=596



1.99
Find all posts by this user
Quote this message in a reply
03-08-2020, 03:38 AM
Post: #6
RE: PO receive error
Ok I deleted line from PO, created new PO and receive the item. No Problem.
Up and running again.

Thank you Tim for the replies, still don't know what cause it, but that are now history.

Regards
Alan
Find all posts by this user
Quote this message in a reply
03-08-2020, 08:37 AM
Post: #7
RE: PO receive error
Glad it's sorted for you Alan. Keep an eye on it and if it happen again let me know.

Tim
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)