Post Reply 
 
Thread Rating:
  • 1 Votes - 1 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Setting up new language
11-19-2013, 11:26 AM
Post: #11
RE: Setting up new language
(11-18-2013 05:57 PM)phil Wrote:  where is weberp/languages?

You click on your user name and select the language from the list. If the list of languages does not display there is something wrong with your installation

I select the language from the list , it display . But it is only english
Find all posts by this user
Quote this message in a reply
11-19-2013, 06:58 PM
Post: #12
RE: Setting up new language
Can you identify if your PHP web-server has gettext installed...
there are some answers in the FAQ at

http://www.weberp.org/wiki/FrequentlyAskedQuestions

Quote:Translations

I selected another language, but it does not work.

It is not yet translated or not completely translated. Or there are technical problems. Let your IT specialist check out the GetText page.
Some possible reasons:
- possibly the server does not have the language code you are asking for installed. You can check from a command line by typing locale -a - to show all the locales installed on your server. The code must be the same as one of the server locale codes.
- the encoding in the messages.po may need to be set or changed from ISO-8959-1. This is actually done by translating the string ISO-8859-1 in the messages.po of the translation you are using. Of course the messages.mo needs to be recreated using msgfmt.exe after having created the messages.po translation.
- your browser may be forcing a different encoding.

Translation Doesn't Work
messages.mo and messages.po for my language have been copied under \locale\id_ID\LC_MESSAGES and the config.php file has been edited:

DefaultLanguage
$DefaultLanguage ='en_GB';
$DefaultLanguage ='id_ID';

I have refreshed my browser and login to weberp but still cant see the new language everything is still in english.
I have installed GNU GetText for Windows and enabled the windows extension for gettext

What step did I miss?

Answer:

You have to change your user account to be id_ID.
Click on your user name at the top of the screen and select the language from the list box - after update

gettext must be enabled in your php installation - then restart apache. There is a file php.ini that needs the gettext module to be enabled. You can check
with the phpinfo.php script in the distribution to see the setup of php it should refer to gettext.

On Linux Systems you can do that with this commands :
> sudo apt-get install gettext ( to install gettext utility)
> sudo apt-get install php-gettext (to install php-gettext extension to your php)
> sudo locale-gen id_ID

and be sure that the translation files have the right permissions for the www-data user .

Phil Daintree
webERP Admin
Logic Works Ltd
http://www.logicworks.co.nz
Visit this user's website Find all posts by this user
Quote this message in a reply
11-20-2013, 09:38 PM
Post: #13
RE: Setting up new language
(11-19-2013 09:45 PM)timschofield Wrote:  Your server needs the correct locale to be installed on it. It will only work then.

Thanks
Tim


I will try
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)