Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Potential Translation Issue - SOLVED
11-30-2018, 03:36 AM (This post was last modified: 11-30-2018 04:35 AM by VortecCPI.)
Post: #1
Potential Translation Issue - SOLVED
SupplierInvoice.php

Is what is shown below correct?
PHP Code:
_('PO'.$identifier
Should we mix values together?

PHP Code:
                        /*now the GRN suspense entry*/
                        
$SQL "INSERT INTO gltrans (type,
                                                    typeno,
                                                    trandate,
                                                    periodno,
                                                    account,
                                                    narrative,
                                                    amount)
                                            VALUES (25,
                                                '" 
$GRN "',
                                                '" 
FormatDateForSQL($DeliveryDate) . "',
                                                '" 
$PeriodNo "',
                                                '" 
$_SESSION['CompanyRecord']['grnact'] . "',
                                                '" 
_('PO'.$identifier) . ': ' $_SESSION['PO'.$identifier]->OrderNo ' ' $_SESSION['PO'.$identifier]->SupplierID ' - ' $OrderLine->StockID ' - ' DB_escape_string($OrderLine->ItemDescription) . ' x ' $OrderLine->ReceiveQty ' @ ' locale_number_format($UnitCost,$_SESSION['CompanyRecord']['decimalplaces']) . "',
                                                '" 
. -$UnitCost $OrderLine->ReceiveQty "'
                                                )"


https://www.linkedin.com/in/eclipsepaulbecker
Visit this user's website Find all posts by this user
Quote this message in a reply
11-30-2018, 04:10 AM
Post: #2
RE: Translation Issue?
You are right. That shouldn't be in the gettext _() function.

Tim
Visit this user's website Find all posts by this user
Quote this message in a reply
11-30-2018, 04:13 AM
Post: #3
RE: Translation Issue?
Thank you Tim!

I noticed this while looking through GL entries and wondered why some use "PO: " and some did not.

https://www.linkedin.com/in/eclipsepaulbecker
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)