Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
webERP 4.14.1 is ignoring language change
08-26-2017, 10:42 PM
Post: #1
webERP 4.14.1 is ignoring language change
Hi folks,

My installation of webERP 4.14.1 is ignoring languange change. I had tried to change language to Bahasa Indonesia from the user menu but it seems like webERP is ignoring the changes.

I had also changed the config file language to id_ID.utf8 but still no luck.

My installation environment is Windows 7, Apache 2.4, PHP 7.1.7 and MariaDB 10.1.25

Is there any suggestions?

Thank you.
Bill RP.


Attached File(s) Thumbnail(s)
       
Find all posts by this user
Quote this message in a reply
08-27-2017, 01:16 AM
Post: #2
RE: webERP 4.14.1 is ignoring language change
I don't know anything about thee windows environment but i know on Linux you have to actually have that locale installed on the server. I am guessing that the problem you are having is connected to that.

a quick Google reveals the following instructions :

Click Start, then Control Panel
Click Clock, Language and Region
Windows 10, Windows 8: Click Region
Windows 7: Click Region and Language
Windows XP: Click Regional and Language Options
The Region and Language options dialog appears.
Click the Administrative tab
On Windows XP, click the Advanced tab
If there is no Advanced tab, then you are not logged in with administrative privileges.
Under the Language for non-Unicode programs section, click Change system locale and select the desired language.
Click OK
Restart the computer to apply the change.

though I am not in a position to test this, but I hope it helps.

Tim
Visit this user's website Find all posts by this user
Quote this message in a reply
08-27-2017, 01:50 AM
Post: #3
RE: webERP 4.14.1 is ignoring language change
(08-27-2017 01:16 AM)falkoner Wrote:  I don't know anything about thee windows environment but i know on Linux you have to actually have that locale installed on the server. I am guessing that the problem you are having is connected to that.

a quick Google reveals the following instructions :

Click Start, then Control Panel
Click Clock, Language and Region
Windows 10, Windows 8: Click Region
Windows 7: Click Region and Language
Windows XP: Click Regional and Language Options
The Region and Language options dialog appears.
Click the Administrative tab
On Windows XP, click the Advanced tab
If there is no Advanced tab, then you are not logged in with administrative privileges.
Under the Language for non-Unicode programs section, click Change system locale and select the desired language.
Click OK
Restart the computer to apply the change.

though I am not in a position to test this, but I hope it helps.

Tim

Hi Tim,

Thank you for your quick reply.

I changed the locale, location, and regional settings to Indonesia, restarted the computer, but still no luck.

The locale language translation for id_ID is avalable in the locale folder of webERP, but why doesn't it work? Why does it need the locale to be installed anyway? for the Indonesian language does not need any special characters.

Would somebody explain how the language translation in webERP works?

Thank you very much,
Bill RP
Find all posts by this user
Quote this message in a reply
08-27-2017, 02:30 AM
Post: #4
RE: webERP 4.14.1 is ignoring language change
It uses the GNU gettext utility (https://www.gnu.org/software/gettext/) to translate strings on the fly. In the code any strings are used as a parameter in a special function _() such as :

_('A sample string')

and when the PHP interpreter encounters this it calls gettext to retrieve the translated string from the relevant .mo file (which is compiled from a .po file using a gettext utility). I know from years of experience that the most common cause of translations not showing is the locale not being present. I can't remember now why gettext requires it but it does.

Looking around there seems to be a lot of queries on stackoverflow regarding windows 7 and gettext so there is maybe something there.

Sorry I can't be of further help, but the answer will lie in your windows/apache configuration somewhere
Tim
Visit this user's website Find all posts by this user
Quote this message in a reply
08-28-2017, 12:51 PM
Post: #5
RE: webERP 4.14.1 is ignoring language change
It would be worth checking that your web-server has gettext utilities installed under your PHP environment
If you write a script
Code:
<?php
phpinfo();
?>
and put this under your webERP install called phpinfo.php or something then point your browser to

http://yourdomain.com/webERP/phpinfo.php

then look down the list of PHP functionality you have installed to see if gettext is actually installed!!

see

http://www.inmotionhosting.com/support/w...p-settings

under windows you will have a php.ini somewhere and you need to ensure that the gettext.dll is enabled.

Phil Daintree
webERP Admin
Logic Works Ltd
http://www.logicworks.co.nz
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)