Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
General Questions
01-04-2013, 03:00 AM
Post: #1
General Questions
In my country we use dots "." instead of commas "," to separate decimal numbers, how do I change it??

When I use the symbol "&" on the name of a customer, I can see it clearly on any page but when I print it on an invoice, it appears as "&" on the PDF file, how do I fix it??

Is there any font friendly with dot-matrix printers?? I have an Epson LX-300 II for Invoices (just text, no lines) but any font I use prints poorly, any solution to this?
Find all posts by this user
Quote this message in a reply
01-04-2013, 05:55 AM
Post: #2
RE: General Questions
What language are you using?
Normally when you change the language, the character that is used for separating the thousands and the decimal point character are determined by the language setting. The character used by each language is in the file includes/LanguagesArray.php

Please do tell what language I have the wrong characters set up for.

I am not sure about your other issues.

Phil Daintree
webERP Admin
Logic Works Ltd
http://www.logicworks.co.nz
Visit this user's website Find all posts by this user
Quote this message in a reply
01-04-2013, 06:08 AM
Post: #3
RE: General Questions
Spanish...
Find all posts by this user
Quote this message in a reply
01-04-2013, 06:18 AM
Post: #4
RE: General Questions
This is the relevant bit of the Lang:agesArray.php - have you selected Spanish abd the number formatting is still not working?

Code:
$LanguagesArray['es_ES.utf8']['LanguageName'] = _('Spanish');
$LanguagesArray['es_ES.utf8']['WindowsLocale'] = 'spanish';
$LanguagesArray['es_ES.utf8']['DecimalPoint'] = ',';
$LanguagesArray['es_ES.utf8']['ThousandsSeparator'] = '.';

Phil Daintree
webERP Admin
Logic Works Ltd
http://www.logicworks.co.nz
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)