Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Having Difficulty with MySQL connection
09-11-2012, 08:10 AM
Post: #11
RE: Having Difficulty with MySQL connection
(08-21-2012 05:01 AM)lemmens_hjm Wrote:  
(08-19-2012 12:00 PM)phil Wrote:  Read through the document under doc/INSTALL.txt and edit your config.php file to use the correct settings. I imagine you have not provided appropriate database name/mysql user name and mysql user password.

Thanks Phil for your feedback. I resolved the matter as per below.

Within the installation wizard = step 5 the company name should be equal - match - the created mysql dbase name created within the hosted environment.

I hope this solution will help others.

Sincerely
H.Lemmens

My problem is similar to others in this thread. However, I still do not have a working system. I made a clean new install, created the database and find the tables have been created. However, the message I get is:
Warning: mysqli_connect() [function.mysqli-connect]: (42000/1044): Access denied for user 'mysqlusername'@'%' to database 'weberp' in ..url..webERP/includes/ConnectDB_mysqli.inc on line 17

Warning: mysqli_set_charset() expects parameter 1 to be mysqli, boolean given in ..url../webERP/includes/ConnectDB_mysqli.inc on line 23
Connect failed: Access denied for user 'mysqlusername'@'%' to database 'weberp'

Clickhereto try logging in again

Note; the mysqlusername is exactly as shown in phpMyAdmin. I cannot understand why the username has a % characters in it? Can somebody shed light on this ?
Find all posts by this user
Quote this message in a reply
09-11-2012, 09:16 AM (This post was last modified: 09-11-2012 09:22 AM by jtrick.)
Post: #12
RE: Having Difficulty with MySQL connection
I just wanted to say that you have to explicitly give permissions to the db user user you want to use for the db you're creating to use for the company in webERP. This is one of a few items that could cause this error, but worth checking because it could be an easy fix for the issue.



Also, do you have the host set to 'localhost' in config.php?

(@~ line 15):
$host = 'localhost';

I didn't run into this issue and it could be something specific to the setup of your host and/or webERP, but this could be part of the problem.
Find all posts by this user
Quote this message in a reply
09-11-2012, 09:48 AM (This post was last modified: 09-11-2012 10:10 AM by WhiteRabit.)
Post: #13
RE: Having Difficulty with MySQL connection
(09-11-2012 09:16 AM)jtrick Wrote:  I just wanted to say that you have to explicitly give permissions to the db user user you want to use for the db you're creating to use for the company in webERP. This is one of a few items that could cause this error, but worth checking because it could be an easy fix for the issue.



Also, do you have the host set to 'localhost' in config.php?

(@~ line 15):
$host = 'localhost';

I didn't run into this issue and it could be something specific to the setup of your host and/or webERP, but this could be part of the problem.

Wow, thanks for the prompt reply. This is a good forum.
Yes, I set the db to use this 'mysqluser' account like other open source software. The application is hosted, and they suggest enabling remote connections.
Host: mysql.serverxxxx.com (same result when $host is 'localhost'
Port: 3306
I did not see where the post can be set.

I found the problem - Company name ie dbname is case sensitive. That means when I use webERP, I have to set that in config and folder name under Companies.
Find all posts by this user
Quote this message in a reply
09-18-2012, 10:31 AM
Post: #14
RE: Having Difficulty with MySQL connection
Glad you got it to work. Yeah, the db name (and by extension company name) has to be used exactly as handled by the db and identical to the directory name that is generated.
Find all posts by this user
Quote this message in a reply
11-07-2012, 04:34 PM
Post: #15
RE: Having Difficulty with MySQL connection
sir i having a problem but i am not able to trouble shoot it please help




when i give my login password and user name

this is the error report i get

Warning: mysqli_connect(): (HY000/1045): Access denied for user 'root'@'localhost' (using password: YES) in C:\xampp\htdocs\webERP\includes\ConnectDB_mysqli.inc on line 17

Warning: mysqli_set_charset() expects parameter 1 to be mysqli, boolean given in C:\xampp\htdocs\webERP\includes\ConnectDB_mysqli.inc on line 23
Connect failed: Access denied for user 'root'@'localhost' (using password: YES)
Find all posts by this user
Quote this message in a reply
11-07-2012, 05:24 PM
Post: #16
RE: Having Difficulty with MySQL connection
Can you connect to mysql using phpMyAdmin?

Phil Daintree
webERP Admin
Logic Works Ltd
http://www.logicworks.co.nz
Visit this user's website Find all posts by this user
Quote this message in a reply
07-21-2016, 12:23 AM
Post: #17
RE: Having Difficulty with MySQL connection
I am having the same problem while installing the program at the end of the installing an error page is displayed.
But when I refresh it shows as if the installation was successful, it displays the logging screen.
When I enter the user - admin and password - weberp an error is displayed

Access denied for user 'root'@'localhost' to database
Click here to try logging in again

I can successfully log in the sql and phpadmin without a password.

can anyone help?
Find all posts by this user
Quote this message in a reply
07-21-2016, 01:32 AM
Post: #18
RE: Having Difficulty with MySQL connection
A couple of things occur to me. Can you check the config.php file and ensure the right database login details are stored there, and secondly is the mysql database on the same machine as the web server?

Thanks
Tim
Visit this user's website Find all posts by this user
Quote this message in a reply
07-21-2016, 05:55 AM
Post: #19
RE: Having Difficulty with MySQL connection
Thanks for your reply.

Yes the MySQL and the Web Server are on the same machine

I am using wamp server, the only difference is that in the config.php the host is number as below

$cfg['Servers'][$i]['host'] = '127.0.0.1';
$cfg['Servers'][$i]['extension'] = 'mysqli';
$cfg['Servers'][$i]['auth_type'] = 'cookie';
$cfg['Servers'][$i]['user'] = '';
$cfg['Servers'][$i]['password'] = '';

Below are the details of the installation error

( ! ) Fatal error: Maximum execution time of 600 seconds exceeded in C:\wamp64\www\webERP\install\index.php on line 1242
Call Stack
# Time Memory Function Location
1 0.0019 565336 {main}( ) ...\index.php:0
2 398.5439 768816 PopulateSQLData( ) ...\index.php:453
3 398.5441 768952 PopulateSQLDataBySQL( ) ...\index.php:1167

With the above error when I enter on the page localhost/webERP
A login page is displayed after entering the user and password below is the message

Connect failed: Access denied for user 'root'@'localhost' (using password: NO)
Click here to try logging in again
Find all posts by this user
Quote this message in a reply
07-21-2016, 08:39 AM
Post: #20
RE: Having Difficulty with MySQL connection
(07-21-2016 05:55 AM)futuretech Wrote:  $cfg['Servers'][$i]['host'] = '127.0.0.1';
$cfg['Servers'][$i]['extension'] = 'mysqli';
$cfg['Servers'][$i]['auth_type'] = 'cookie';
$cfg['Servers'][$i]['user'] = '';
$cfg['Servers'][$i]['password'] = '';

I think this is from your WAMP config.php. It was the config.php file under your webERP directory I meant.

Sorry for not explaining properly,

Tim
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)