Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
GL Import error
10-06-2015, 07:54 AM
Post: #1
GL Import error
Hi All
I have two servers setup one lab and one production I was able to import the GL accounts into the Lab server with no problem but when I try to import into the production server I get the following error.
Both server are setup exactly the same.

Database Error 1366 :
Incorrect integer value: '' for column 'chequeno' at row 1
Database SQL Failure : The SQL that failed was
INSERT INTO gltrans (type, typeno, chequeno, trandate, periodno, account, narrative, amount, tag ) VALUES ( '0', '4', '', '2015-9-1', '4', '1000', 'Import from Facts system', '-121741.09', '' )

Any help would be appreciated.
Thanks
Davwe
Find all posts by this user
Quote this message in a reply
10-06-2015, 08:02 AM
Post: #2
RE: GL Import error
The fields is expecting an integer, not null.
If you change your input file to have that field be '0' instead of '' does it work?

When you say both servers are exactly the same does that include the software release versions of PHP and MySQL?
Find all posts by this user
Quote this message in a reply
10-06-2015, 08:52 AM
Post: #3
RE: GL Import error
I did some checking the production MySQL is setup different, in the my.ini it is set to strict mode.
# Set the SQL mode to strict
sql-mode="STRICT_TRANS_TABLES,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION"
do you know what mode it needs to be and what should I change the above line to.
Thanks
Dave
Find all posts by this user
Quote this message in a reply
10-06-2015, 10:28 AM
Post: #4
RE: GL Import error
I got it I used the line
sql-mode="NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION"
in the my.ini file.
Thanks
All
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)