Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Install problems with 4.1.2.2
03-26-2015, 06:09 PM,
#1
Install problems with 4.1.2.2
Hi
I couldn't get 4.12.2 to install at all even after following the correct steps, however when I used Softaculous, I managed to get 4.11.3 installed correctly, now my question is can I copy the files for 4.12.2 straight over the existing ones and it should work OK?

Also how to I remove all the dummy data so I can start afresh?

Andylira
Reply
03-27-2015, 05:04 AM,
#2
RE: Install problems with 4.1.2.2
What issues did you encounter?
Screen shot might be useful of where the problem occurred.
You get a choice when using the install wizard to create a new company.
You can also use Z_CreateCompany.php - assuming privileges are appropriately set to allow write access to the companies folder.
Phil Daintree
webERP Admin
Logic Works Ltd
http://www.logicworks.co.nz
Reply
03-27-2015, 05:39 PM, (This post was last modified: 03-27-2015, 06:03 PM by andylira.)
#3
RE: Install problems with 4.1.2.2
Phil
I have expanded the tar and got the install of 4.11.2, I then followed the instructions of https://support.exabytes.com/kb/a2789/in...panel.aspx, which I picked from the forum as it most suited my install, being via c-panel on linux server etc etc. I also downloaded the file from his link.
But all I get when I try to access the install is this
(none) /webERP/install/index.php Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2272.101 Safari/537.36 50041.202.228.38 YOU ARE JUST SO NOT ALLOWED HERE, KINDLY LEAVE !!!!!
I have tried all the permissions up to 7777 to no avail, what really bemuses me is if I install from Softaculous, all is well and I can make a new company etc,
Please a solution to my quandry


Phil
Just a note on this issue, when I look at the file /home/apbtsuga/public_html/webERP/sql/mysql/country_sql/default.sql
It has the following at the top

SET FOREIGN_KEY_CHECKS = 0;
-- MySQL dump 10.14 Distrib 5.5.40-MariaDB, for debian-linux-gnu (x86_64)
--
-- Host: localhost Database: weberpdb
-- ------------------------------------------------------
-- Server version 5.5.40-MariaDB-0ubuntu0.14.04.1
/*!40103 SET @OLD_TIME_ZONE=@@TIME_ZONE */;
/*!40103 SET TIME_ZONE='+00:00' */;
/*!40014 SET @OLD_UNIQUE_CHECKS=@@UNIQUE_CHECKS, UNIQUE_CHECKS=0 */;
/*!40014 SET @OLD_FOREIGN_KEY_CHECKS=@@FOREIGN_KEY_CHECKS, FOREIGN_KEY_CHECKS=0 */;
/*!40101 SET @OLD_SQL_MODE=@@SQL_MODE, SQL_MODE='NO_AUTO_VALUE_ON_ZERO' */;
/*!40111 SET @OLD_SQL_NOTES=@@SQL_NOTES, SQL_NOTES=0 */;

This refers to MariaDB which is contrary to the MySQLi that I am using, could this be an issue?
Reply
03-30-2015, 05:36 PM,
#4
RE: Install problems with 4.1.2.2
Have you read

http://www.weberp.org/weberp/doc/INSTALL.txt

Having extracted the files have you tried to go to

http://yourdomain/webERP

where yourdomain in the web-root that serves the files from

/home/apbtsuga/public_html/

this should bring up the install wizard
Phil Daintree
webERP Admin
Logic Works Ltd
http://www.logicworks.co.nz
Reply
03-30-2015, 08:40 PM,
#5
RE: Install problems with 4.1.2.2
Phil

I have extracted the zip again and when I enter the url https:/btsuga.com/webERP/ all I get is that message I sent you before from the site, this applies also if I try to use the install directory.

The new folder has 0777 permissions so I dont understand whats causing it, any advice would be great?

Andylira



(03-30-2015, 05:36 PM)phil Wrote: Have you read

http://www.weberp.org/weberp/doc/INSTALL.txt

Having extracted the files have you tried to go to

http://yourdomain/webERP

where yourdomain in the web-root that serves the files from

/home/apbtsuga/public_html/

this should bring up the install wizard



Attached Files Thumbnail(s)
   
Reply
03-31-2015, 05:44 PM,
#6
RE: Install problems with 4.1.2.2
Perhaps the web-server needs to be configured to allow this directory? You may have to define the webERP folder as a valid directory to serve web-pages from.
Maybe 775 permissions?
Sorry don't really know why this doesn't work for you other than that it is a web-server configuration issue.
Phil Daintree
webERP Admin
Logic Works Ltd
http://www.logicworks.co.nz
Reply
03-31-2015, 10:51 PM,
#7
RE: Install problems with 4.1.2.2
Hi Phil

Thanks, after a deal of struggle I get that the issue is that [PHP] is not loading MBSTRING as i get the message:-

The php-mbstring extension has not been installed or loaded, please correct your php configuration first

In the install file there is reference to a .htaccess file where I could configure this but I dont see this in my install, where can I down load or what should I put in it to rectify this issue if I make a new file?
Andylira


Reply
04-01-2015, 12:45 AM, (This post was last modified: 04-01-2015, 12:45 AM by falkoner.)
#8
RE: Install problems with 4.1.2.2
The mbstring extension needs to be installed by whoever is administering your server. If you are using a hosting company (I take it from the fact that you are using cpanel that you are) then just ask them to install it for you.

Tim
Reply
04-01-2015, 09:41 AM,
#9
RE: Install problems with 4.1.2.2
With some web-hosts you can choose which extensions you wish to have and they have a check box against the extensions you can choose.
Phil Daintree
webERP Admin
Logic Works Ltd
http://www.logicworks.co.nz
Reply
04-01-2015, 06:32 PM,
#10
RE: Install problems with 4.1.2.2
Tim
Thanks for that my site was recently shifted to a new server by the provider and I guess this one doesn't have the PHP properly configured, so I have done as you suggest and requested them to fix it, lets see what happens.
Andylira


(04-01-2015, 12:45 AM)falkoner Wrote: The mbstring extension needs to be installed by whoever is administering your server. If you are using a hosting company (I take it from the fact that you are using cpanel that you are) then just ask them to install it for you.

Tim

Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)