Post Reply 
 
Thread Rating:
  • 1 Votes - 4 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Login Loop
03-09-2015, 08:06 AM
Post: #1
Login Loop
I'm running 4.11

This was working fine until this afternoon when I went to check something.

I get the screen asking for username and password. I click "Login". The next screen gives me main screen:

Error in form verification
Main Menu
Customers
Items
Vendors
Manual
Logout
ERROR Message Report : This form was not submitted with a correct ID

This error message is not out of the ordinary.

But the problem is the next click. If I click any of the 4 menu items (not manual or logout) I get redirected to the login screen. It's an endless loop. This is all I am allowed to do.
Find all posts by this user
Quote this message in a reply
03-09-2015, 10:09 AM
Post: #2
RE: Login Loop
Have you changed a script?
The session.inc has for many years checked that form submissions come from a webERP script.

Phil Daintree
webERP Admin
Logic Works Ltd
http://www.logicworks.co.nz
Visit this user's website Find all posts by this user
Quote this message in a reply
03-09-2015, 11:59 AM
Post: #3
RE: Login Loop
No script has been changed. It logged in fine on Saturday morning. I went away on a short vacation to the Everglades and it stopped working on Sunday evening when I came back.
Find all posts by this user
Quote this message in a reply
03-09-2015, 12:14 PM
Post: #4
RE: Login Loop
Thought you were running 4.12.2 now too?

Phil Daintree
webERP Admin
Logic Works Ltd
http://www.logicworks.co.nz
Visit this user's website Find all posts by this user
Quote this message in a reply
03-09-2015, 04:38 PM
Post: #5
RE: Login Loop
Hello there,

Please try clearing everything in browser cache and try logging in again.

If you get the same massage you can click logout on the menu and then it should be redirected to the login form to login.

Thanks
Find all posts by this user
Quote this message in a reply
03-09-2015, 06:41 PM
Post: #6
RE: Login Loop
I get the same message on your install... I am wondering about the session save path - perhaps the host is using a more interesting load balancing arrangement. If the machine doing the serving changes or could change between calls then the session save path could change and be lost. I have an idea to fix it if this might be it.

Phil Daintree
webERP Admin
Logic Works Ltd
http://www.logicworks.co.nz
Visit this user's website Find all posts by this user
Quote this message in a reply
03-10-2015, 07:26 AM
Post: #7
RE: Login Loop
I got my webhost to install the database backup from a day ago. I guess the mySQL database was corrupt during the daily backup. It's working now.
Find all posts by this user
Quote this message in a reply
03-10-2015, 03:13 PM
Post: #8
RE: Login Loop
Ah - glad you are sorted...

Phil Daintree
webERP Admin
Logic Works Ltd
http://www.logicworks.co.nz
Visit this user's website Find all posts by this user
Quote this message in a reply
06-10-2015, 05:09 PM
Post: #9
RE: Login Loop
Dear Mr. Phil,

I am stuck in above mentioned problem and search alot but could able to get rid from that problem.

Regards,

Umar
Find all posts by this user
Quote this message in a reply
06-10-2015, 09:04 PM
Post: #10
RE: Login Loop
This problem is normally caused by the fact that the web server cannot write to the directory where session information is stored. The default can be over written in config.php by oncommenting this line:

//$SessionSavePath = '/tmp';

have you done this? If not then you need to check with whoever supports your server to check this directory.

Thanks
Tim
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)