Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Which PHP version as minimum for webERP?
03-28-2014, 11:44 AM,
#7
RE: Which PHP version as minimum for webERP?
Dear all,

(03-28-2014, 05:40 AM)phil Wrote: I prefer we keep to pretty basic PHP functions as far as possible - this policy has stood us in pretty good stead throughout the various incarnations of PHP over time.

I vote for this. webERP is an application which used in Business environment, and the target is SME. It's a merit that webERP can be run across many PHP version. I think the idea one is 'PHP version independent'. So the users only need to upgrade their webERP application instead of environment.

As Tim point out, lots of hosting company still use heavily patched php5.2. I'm glad to see that webERP worked pretty well in php5.2 and php5.3. I know this because I use appserv which stayed in php5.2.6 and I use wamp too. And I've experienced another projects which absolutely failed php5.3. So it has to be distributed with a php 5.2 environment packing.

Although we have not introduced most brand new features, webERP still performance very well over many projects.

So the policy has been tested by practice and the results can be reviewed by everyone. I vote to stick to it instead of pursuing those brand new features which may deprecated very soon. It'll waste developers' time and also hurt the users.

Keeping webERP's pragmatic way is a must. If there is problem, dig it out and fix it. To constraint ourselves and enhance webERP's dependable on environments is never a good choice, IMHO.

Best regards!
Exson





Reply


Messages In This Thread
RE: Which PHP version as minimum for webERP? - by Exsonqu_Qu - 03-28-2014, 11:44 AM

Forum Jump:


Users browsing this thread: 2 Guest(s)