Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Which PHP version as minimum for webERP?
03-28-2014, 01:17 AM,
#2
RE: Which PHP version as minimum for webERP?
For my two cents
PHP 5.2 reached end of life 3 years ago. PHP 5.3 is supposed to reach end of life this year, although it keeps being delayed, likely as it already difficult for people to switch from PHP 5.2 -> 5.3 let alone from 5.3 -> 5.4.
I'm okay with keeping a stable legacy branch but my vote would be to support continued development on PHP 5.4+ as the minimum. PHP 5.4 will reach end of life next year, which means we still have 3 years (this year, next year and the year after) before it is fully unsupported. I would like to move to PHP 5.5 since it has a built-in optimizer which will make the code run a lot faster, (and also reduce overheads of classes etc.) but I don't think it's well distributed yet, a non-technical user who downloads xampp or wamp to make a web server will likely have PHP 5.4, which makes it a good balance between looking towards future support and also ease of installation etc.
Reply


Messages In This Thread
RE: Which PHP version as minimum for webERP? - by serakfalcon - 03-28-2014, 01:17 AM

Forum Jump:


Users browsing this thread: 2 Guest(s)