Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Error in security setup
10-27-2013, 04:02 AM
Post: #1
Error in security setup
Hello,

I have a problem after install weberp, I could install it on my hosted server and I accessed without trouble to my database. But after login on the system weberp this error message appear:

ERROR Message Report : Your user role does not have any access defined for webERP. There is an error in the security setup for this user account.

Can you help me with this problem?

Thanks!
Find all posts by this user
Quote this message in a reply
10-27-2013, 08:18 AM
Post: #2
RE: Error in security setup
Is this the admin user or some other user?
How did you create the user?
Could you post the user set up screen - www_users.php?

Phil Daintree
webERP Admin
Logic Works Ltd
http://www.logicworks.co.nz
Visit this user's website Find all posts by this user
Quote this message in a reply
10-27-2013, 09:55 AM
Post: #3
RE: Error in security setup
(10-27-2013 08:18 AM)phil Wrote:  Is this the admin user or some other user?
How did you create the user?
Could you post the user set up screen - www_users.php?

Hi Phil, thank you for your help. The user is the admin and has all privileges on the database. The user was created using a website administrator.

I've attached the file www_users.php

Thanks again!!


Attached File(s)
.php  WWW_Users.php (Size: 24.77 KB / Downloads: 3)
Find all posts by this user
Quote this message in a reply
10-27-2013, 10:52 PM
Post: #4
RE: Error in security setup
(10-27-2013 11:27 AM)timschofield Wrote:  
(10-27-2013 09:55 AM)diegorbarca Wrote:  
(10-27-2013 08:18 AM)phil Wrote:  Is this the admin user or some other user?
How did you create the user?
Could you post the user set up screen - www_users.php?

Hi Phil, thank you for your help. The user is the admin and has all privileges on the database. The user was created using a website administrator.

I've attached the file www_users.php

Thanks again!!

Hello, the webERP user is different than the database user. You should have created an admin user during the install.

Another perhaps silly question, is have you tried clicking on logout, and then logging back in again?

Thanks
Tim


Hi Tim, yes the users are different and Itried logout and login again many time. I think that de problem is in some record of securitygroups tables but I don't know what exactly I have to do.

Thank you
Find all posts by this user
Quote this message in a reply
10-28-2013, 04:37 AM
Post: #5
RE: Error in security setup
(10-28-2013 04:24 AM)timschofield Wrote:  
(10-27-2013 10:52 PM)diegorbarca Wrote:  
(10-27-2013 11:27 AM)timschofield Wrote:  
(10-27-2013 09:55 AM)diegorbarca Wrote:  
(10-27-2013 08:18 AM)phil Wrote:  Is this the admin user or some other user?
How did you create the user?
Could you post the user set up screen - www_users.php?

Hi Phil, thank you for your help. The user is the admin and has all privileges on the database. The user was created using a website administrator.

I've attached the file www_users.php

Thanks again!!

Hello, the webERP user is different than the database user. You should have created an admin user during the install.

Another perhaps silly question, is have you tried clicking on logout, and then logging back in again?

Thanks
Tim


Hi Tim, yes the users are different and Itried logout and login again many time. I think that de problem is in some record of securitygroups tables but I don't know what exactly I have to do.

Thank you

Hi, first off just check that the `fullaccess` field in www_users table is set to 8 for your admin users.

Tim

Hi, the field is set to 8 for the user admin, it's the only user too.

Thanks!
Diego
Find all posts by this user
Quote this message in a reply
10-28-2013, 06:31 AM
Post: #6
RE: Error in security setup
(10-28-2013 06:03 AM)timschofield Wrote:  Ok, then next question is what is the value of the pagesecurity field in the scripts table for the script index.php

Tim

Hi, this value is 1, is it the correct value?

Diego
Find all posts by this user
Quote this message in a reply
10-28-2013, 07:03 AM (This post was last modified: 10-28-2013 07:05 AM by diegorbarca.)
Post: #7
RE: Error in security setup
(10-28-2013 06:47 AM)timschofield Wrote:  
(10-28-2013 06:31 AM)diegorbarca Wrote:  
(10-28-2013 06:03 AM)timschofield Wrote:  Ok, then next question is what is the value of the pagesecurity field in the scripts table for the script index.php

Tim

Hi, this value is 1, is it the correct value?

Diego

Hi Diego, 1 is ok, and you have a record in table securitygroups with value 8 in secroleid and 1 in tokenid?

Thanks
Tim
Hi Tim, I don't have this values in table securitygroups, that's the problem? In what record I should have these values?

Thanks to you tim

(10-28-2013 06:47 AM)timschofield Wrote:  
(10-28-2013 06:31 AM)diegorbarca Wrote:  
(10-28-2013 06:03 AM)timschofield Wrote:  Ok, then next question is what is the value of the pagesecurity field in the scripts table for the script index.php

Tim

Hi, this value is 1, is it the correct value?

Diego

Hi Diego, 1 is ok, and you have a record in table securitygroups with value 8 in secroleid and 1 in tokenid?

Thanks
Tim


Hi Tim, i don't have these values, that's the possible problem? In what record I should have these values in secroleid and tokenid?

Thank you tim
Find all posts by this user
Quote this message in a reply
10-28-2013, 07:15 AM
Post: #8
RE: Error in security setup
(10-28-2013 07:06 AM)timschofield Wrote:  Yes Diego that is the problem. Run the following sql:

INSERT INTO `securitygroups` VALUES (8,0);
INSERT INTO `securitygroups` VALUES (8,1);
INSERT INTO `securitygroups` VALUES (8,2);
INSERT INTO `securitygroups` VALUES (8,3);
INSERT INTO `securitygroups` VALUES (8,4);
INSERT INTO `securitygroups` VALUES (8,5);
INSERT INTO `securitygroups` VALUES (8,6);
INSERT INTO `securitygroups` VALUES (8,7);
INSERT INTO `securitygroups` VALUES (8,8);
INSERT INTO `securitygroups` VALUES (8,9);
INSERT INTO `securitygroups` VALUES (8,10);
INSERT INTO `securitygroups` VALUES (8,11);
INSERT INTO `securitygroups` VALUES (8,12);
INSERT INTO `securitygroups` VALUES (8,13);
INSERT INTO `securitygroups` VALUES (8,14);
INSERT INTO `securitygroups` VALUES (8,15);

and it should work for that user.

Tim

Tim, when I tried to run this sql sentence i have the follow error:

#1452 - Cannot add or update a child row: a foreign key constraint fails (`673997_weberp`.`securitygroups`, CONSTRAINT `securitygroups_tokenid_fk` FOREIGN KEY (`tokenid`) REFERENCES `securitytokens` (`tokenid`))

Do you know what is that?

Thanks
Find all posts by this user
Quote this message in a reply
10-28-2013, 08:17 AM
Post: #9
RE: Error in security setup
(10-28-2013 08:03 AM)timschofield Wrote:  Hi Diego, we are getting close :-)

Run this first:


INSERT INTO `securitytokens` VALUES (0,'Main Index Page');
INSERT INTO `securitytokens` VALUES (1,'Order Entry/Inquiries customer access only');
INSERT INTO `securitytokens` VALUES (2,'Basic Reports and Inquiries with selection options');
INSERT INTO `securitytokens` VALUES (3,'Credit notes and AR management');
INSERT INTO `securitytokens` VALUES (4,'Purchasing data/PO Entry/Reorder Levels');
INSERT INTO `securitytokens` VALUES (5,'Accounts Payable');
INSERT INTO `securitytokens` VALUES (6,'Petty Cash');
INSERT INTO `securitytokens` VALUES (7,'Bank Reconciliations');
INSERT INTO `securitytokens` VALUES (8,'General ledger reports/inquiries');
INSERT INTO `securitytokens` VALUES (9,'Supplier centre - Supplier access only');
INSERT INTO `securitytokens` VALUES (10,'General Ledger Maintenance, stock valuation & Configuration');
INSERT INTO `securitytokens` VALUES (11,'Inventory Management and Pricing');
INSERT INTO `securitytokens` VALUES (12,'Prices Security');
INSERT INTO `securitytokens` VALUES (13,'Customer services Price modifications');
INSERT INTO `securitytokens` VALUES (14,'Unknown');
INSERT INTO `securitytokens` VALUES (15,'User Management and System Administration');

Tim

Hi, I run these scripts and the others with success. When I logout and login again. Appear more options like customers, Items and so on after updating the tables but I have the same error. Can I try something else?

Thanks
Find all posts by this user
Quote this message in a reply
10-28-2013, 08:45 AM
Post: #10
RE: Error in security setup
(10-28-2013 08:27 AM)timschofield Wrote:  
(10-28-2013 08:17 AM)diegorbarca Wrote:  
(10-28-2013 08:03 AM)timschofield Wrote:  Hi Diego, we are getting close :-)

Run this first:


INSERT INTO `securitytokens` VALUES (0,'Main Index Page');
INSERT INTO `securitytokens` VALUES (1,'Order Entry/Inquiries customer access only');
INSERT INTO `securitytokens` VALUES (2,'Basic Reports and Inquiries with selection options');
INSERT INTO `securitytokens` VALUES (3,'Credit notes and AR management');
INSERT INTO `securitytokens` VALUES (4,'Purchasing data/PO Entry/Reorder Levels');
INSERT INTO `securitytokens` VALUES (5,'Accounts Payable');
INSERT INTO `securitytokens` VALUES (6,'Petty Cash');
INSERT INTO `securitytokens` VALUES (7,'Bank Reconciliations');
INSERT INTO `securitytokens` VALUES (8,'General ledger reports/inquiries');
INSERT INTO `securitytokens` VALUES (9,'Supplier centre - Supplier access only');
INSERT INTO `securitytokens` VALUES (10,'General Ledger Maintenance, stock valuation & Configuration');
INSERT INTO `securitytokens` VALUES (11,'Inventory Management and Pricing');
INSERT INTO `securitytokens` VALUES (12,'Prices Security');
INSERT INTO `securitytokens` VALUES (13,'Customer services Price modifications');
INSERT INTO `securitytokens` VALUES (14,'Unknown');
INSERT INTO `securitytokens` VALUES (15,'User Management and System Administration');

Tim

Hi, I run these scripts and the others with success. When I logout and login again. Appear more options like customers, Items and so on after updating the tables but I have the same error. Can I try something else?

Thanks

Ok, so you can login and see the menu? Thats good. The whole of the securitygroups table you seem to be missing is the following:

INSERT INTO `securitygroups` VALUES (1,0);
INSERT INTO `securitygroups` VALUES (1,1);
INSERT INTO `securitygroups` VALUES (1,2);
INSERT INTO `securitygroups` VALUES (1,5);
INSERT INTO `securitygroups` VALUES (2,0);
INSERT INTO `securitygroups` VALUES (2,1);
INSERT INTO `securitygroups` VALUES (2,2);
INSERT INTO `securitygroups` VALUES (2,11);
INSERT INTO `securitygroups` VALUES (3,0);
INSERT INTO `securitygroups` VALUES (3,1);
INSERT INTO `securitygroups` VALUES (3,2);
INSERT INTO `securitygroups` VALUES (3,3);
INSERT INTO `securitygroups` VALUES (3,4);
INSERT INTO `securitygroups` VALUES (3,5);
INSERT INTO `securitygroups` VALUES (3,11);
INSERT INTO `securitygroups` VALUES (4,0);
INSERT INTO `securitygroups` VALUES (4,1);
INSERT INTO `securitygroups` VALUES (4,2);
INSERT INTO `securitygroups` VALUES (4,5);
INSERT INTO `securitygroups` VALUES (5,0);
INSERT INTO `securitygroups` VALUES (5,1);
INSERT INTO `securitygroups` VALUES (5,2);
INSERT INTO `securitygroups` VALUES (5,3);
INSERT INTO `securitygroups` VALUES (5,11);
INSERT INTO `securitygroups` VALUES (6,0);
INSERT INTO `securitygroups` VALUES (6,1);
INSERT INTO `securitygroups` VALUES (6,2);
INSERT INTO `securitygroups` VALUES (6,3);
INSERT INTO `securitygroups` VALUES (6,4);
INSERT INTO `securitygroups` VALUES (6,5);
INSERT INTO `securitygroups` VALUES (6,6);
INSERT INTO `securitygroups` VALUES (6,7);
INSERT INTO `securitygroups` VALUES (6,8);
INSERT INTO `securitygroups` VALUES (6,9);
INSERT INTO `securitygroups` VALUES (6,10);
INSERT INTO `securitygroups` VALUES (6,11);
INSERT INTO `securitygroups` VALUES (7,0);
INSERT INTO `securitygroups` VALUES (7,1);
INSERT INTO `securitygroups` VALUES (9,0);
INSERT INTO `securitygroups` VALUES (9,9);

Run these and. If you can't get past the menus then can you let me know which script you can't get into after index.php

Thanks
Tim

Hi Tim, I run these sentences with success. I attached a screen shot with the index.php. When i change de menu the system tells me that my database is not in the same version like de weberp (4.11.0)

Thanks!


Attached File(s) Thumbnail(s)
   
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)