Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Which PHP version as minimum for webERP?
03-28-2014, 05:40 AM,
#6
RE: Which PHP version as minimum for webERP?
What are the PHP features that we currently use that will be gone in 5.4?

The only thing I was aware of was the demise of the old mysql - so our $DBType='mysql' is history. We have the upgrade with mysqli already and if seakfalcon writes us a new DBType='dbal' that would be cool to support a host of other DBs - we would need another config option in config.php I think for $DBDbalType=?? to select the dbal DB type - which would be ignored if DBType!='dbal'

We need to update the readme - and prerequisites to recommend PHP 5.4+ but is that all it is?

I prefer we keep to pretty basic PHP functions as far as possible - this policy has stood us in pretty good stead throughout the various incarnations of PHP over time.
Phil Daintree
webERP Admin
Logic Works Ltd
http://www.logicworks.co.nz
Reply


Messages In This Thread
RE: Which PHP version as minimum for webERP? - by phil - 03-28-2014, 05:40 AM

Forum Jump:


Users browsing this thread: 1 Guest(s)