Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Which PHP version as minimum for webERP?
03-28-2014, 01:29 AM,
#4
RE: Which PHP version as minimum for webERP?
(03-28-2014, 01:20 AM)Uhuru Wrote: I think the obvious question is what aspect of 5.3 and above do you want to use?

Yeah that is the key right there.

For me, the biggest thing I would like to be able to use is traits, specifically for the Views project I'm working on: if I define all the classes as traits, and the 'core' classes are just a collection of traits, someone who wants to override a class and provide their own functionality, can just add the trait that their custom class, and replace the functions they want to override without having to modify the core code or completely copy it. However, I will survive without it.

The next use would be that parametrized queries for mysqli are easier to write if you can use ReflectionMethod, but PDO would not need that and legacy PHP has call_user_funct_array which is convoluted but gets the job done, so it is possible to avoid.
Reply


Messages In This Thread
RE: Which PHP version as minimum for webERP? - by serakfalcon - 03-28-2014, 01:29 AM

Forum Jump:


Users browsing this thread: 2 Guest(s)