webERP Forum
Report Writer Template Scripts - Stray "/"? - Printable Version

+- webERP Forum (http://www.weberp.org/forum)
+-- Forum: webERP Discussion (/forumdisplay.php?fid=1)
+--- Forum: Problems / Bugs? (/forumdisplay.php?fid=8)
+--- Thread: Report Writer Template Scripts - Stray "/"? (/showthread.php?tid=8275)



Report Writer Template Scripts - Stray "/"? - VortecCPI - 12-06-2018 10:47 PM

In all the template scripts we have:

PHP Code:
<input type="hidden" name="FormID" value="<?php echo $_SESSION['FormID']; ?>" /> 

Please not the closing "/" at the end.

Should this be:

PHP Code:
<input type="hidden" name="FormID" value="<?php echo $_SESSION['FormID']; ?>"



RE: Report Writer Template Scripts - Stray "/"? - TurboPT - 12-08-2018 01:46 PM

Yeah, there is some mixed use of XHTML format over non-XHTML usage here and there.

I'll fix that one tomorrow.


RE: Report Writer Template Scripts - Stray "/"? - TurboPT - 12-09-2018 02:50 AM

Paul,

Is this causing an artifact or some other issue?

Searching the entire reportwriter area, I could only find one input with a closing />

If I search for: input*/> finds a few other entries, but due to a <br/> tag at the end of the line, but not at the input.


RE: Report Writer Template Scripts - Stray "/"? - falkoner - 12-09-2018 03:02 AM

The report writer was written in a different style from the rest of webERP. The problem is that the guy who wrote it left the project and nobody has taken up maintaining it.


RE: Report Writer Template Scripts - Stray "/"? - TurboPT - 12-09-2018 03:34 AM

I have in my 'backlog' list to rewrite that area, but figured it to be a lower priority? (I could be wrong, though)


RE: Report Writer Template Scripts - Stray "/"? - falkoner - 12-09-2018 04:04 AM

It's a big job which is why everybody has kept away from it!