webERP Forum
Report Builder - Fonts Ignored - SOLVED - Printable Version

+- webERP Forum (http://www.weberp.org/forum)
+-- Forum: webERP Discussion (/forumdisplay.php?fid=1)
+--- Forum: Problems / Bugs? (/forumdisplay.php?fid=8)
+--- Thread: Report Builder - Fonts Ignored - SOLVED (/showthread.php?tid=8122)



Report Builder - Fonts Ignored - SOLVED - VortecCPI - 03-07-2018 05:09 AM

The Report Builder ignores font name and size.

It has been addressed here in WriteReport.inc: http://www.weberp.org/forum/showthread.php?tid=8110&pid=14509#pid14509


RE: Report Builder - Fonts Ignored - SOLVED - TurboPT - 03-07-2018 09:31 AM

Changes committed.


RE: Report Builder - Fonts Ignored - SOLVED - VortecCPI - 03-08-2018 06:54 AM

I found even more issues with this script.

The Data borders were not correct and the Data and Totals fonts were also ignoring some attributes.

I also added the ability to put %time% in the report header.


RE: Report Builder - Fonts Ignored - SOLVED - TurboPT - 03-08-2018 07:57 AM

Yeah, (and I've mentioned this to Tim via email) I'd like to entirely redo the reportwriter feature at some point.

That feature has been around since before my time with webERP.

Though the feature generally works, as others have used, as well as I for general testing reported forum issues in this area ... the Eclipse validator has ~500 complaints in that area alone. (invalid tag locations, invalid attributes, and more)

Heck, thinking about it just now, since we've moved to GitHub, I might create a branch on my area to begin the effort. As this will take some time to complete anyway between other tangents... at least I can reuse some things there, such as the definitions and certain other portions, so it won't entirely be "from scratch", per say.


RE: Report Builder - Fonts Ignored - SOLVED - VortecCPI - 03-08-2018 08:25 AM

(03-08-2018 07:57 AM)TurboPT Wrote:  Yeah, (and I've mentioned this to Tim via email) I'd like to entirely redo the reportwriter feature at some point.

That feature has been around since before my time with webERP.

Though the feature generally works, as others have used, as well as I for general testing reported forum issues in this area ... the Eclipse validator has ~500 complaints in that area alone. (invalid tag locations, invalid attributes, and more)

This feature is a necessity for our business to manage monthly commissions and quarterly taxes. I could do it externally using MS Access on top of MySQL via DSNless connection but I really don't like that option. I want it all to live in webERP. Therefore I am willing to help out in this area in any way I can. Perhaps there are some OSS alternatives we could integrate with webERP?

The Report Builder idea is great but it is not fully baked...


RE: Report Builder - Fonts Ignored - SOLVED - falkoner - 03-08-2018 08:48 PM

Speaking from a purely mercenary point of view, writing highly customised reports for companies has always been a good source of income for the developers, and helps to subsidise the writing of the main code. However this means that the incentive to write a report writer is low Smile

Tim


RE: Report Builder - Fonts Ignored - SOLVED - VortecCPI - 03-08-2018 10:23 PM

(03-08-2018 08:48 PM)falkoner Wrote:  Speaking from a purely mercenary point of view, writing highly customised reports for companies has always been a good source of income for the developers, and helps to subsidise the writing of the main code. However this means that the incentive to write a report writer is low Smile

Tim

100% agreed as I have been compensated for the development and/or modification of many Crystal Reports and other custom reports (even AS/400). In my opinion we need this lightweight feature in webERP and for our needs it is best if the solution is self-contained.

Of course there are some issues but the idea is sound and adds value to webERP. I will continue to help and contribute in any way I can. I see your point with respect to validation so perhaps I will work with you to target certain areas to tackle a little bit at a time...


RE: Report Builder - Fonts Ignored - SOLVED - phil - 03-09-2018 05:18 AM

Yes a lightweight report writer is a fantastic facility and this has done the job for us ... I think the OCD amongst us have had to grit our teeth at the inconsistent nature of the existing report writer coding on the basis of the important function that it has within webERP. I have often thought this would be an area I would dearly like to fix properly but it is quite a tough area and heck it has worked ... mostly.
I can only offer moral support for this initiative sadly but ... GO PAUL T!!


RE: Report Builder - Fonts Ignored - SOLVED - TurboPT - 03-09-2018 05:32 AM

(03-09-2018 05:18 AM)phil Wrote:  ... I think the OCD amongst us have had to grit our teeth at the inconsistent nature of the existing report writer coding on the basis of the important function that it has within webERP.

Yeah, on the occasions that I have to delve into the reportwriter, I typically have to "Forrest Gump" the code for awhile to [re]gain the perspective.

If you're not sure of the Forrest Gump reference: Forrest has moments when he quietly stares for long periods of time with his head titled to one side.


RE: Report Builder - Fonts Ignored - SOLVED - VortecCPI - 03-09-2018 06:42 AM

I added a few more "Last XYZ To Date" periods to the scripts here: http://www.weberp.org/forum/showthread.php?tid=8110&pid=14567#pid14567