webERP Forum
PDFs Have Suddenly Stopped Displaying - Printable Version

+- webERP Forum (http://www.weberp.org/forum)
+-- Forum: webERP Discussion (/forumdisplay.php?fid=1)
+--- Forum: Problems / Bugs? (/forumdisplay.php?fid=8)
+--- Thread: PDFs Have Suddenly Stopped Displaying (/showthread.php?tid=3318)

Pages: 1 2 3 4 5


PDFs Have Suddenly Stopped Displaying - sunshinelock - 03-23-2017 02:50 AM

I am running 4.11.5

I've been using 4.11.5 for a bit over 2 years now. I print invoices daily.

Yesterday I wasn't able to print any pdf files with the PrintCustTrans.php page, and other various pdf pages have stopped working as well.

I asked my web host if anything has changed since Friday (the last day I would have generated a successful pdf). They tell me that nothing has changed.

I've spent the last 4 hours sorting through my files and don't see anything obvious.

Please help me work this bug out of my system.

Thank you.


RE: PDFs Have Suddenly Stopped Displaying - falkoner - 03-23-2017 02:58 AM

What exactly happens when you try to print?

Is it just invoices or is it all PDFs?

Tim


RE: PDFs Have Suddenly Stopped Displaying - sunshinelock - 03-23-2017 03:19 AM

I get a completely blank page. No HTML code within it whatsoever.

And the pages I know generate PDFs, yes. For instance, I just ran ReorderLevel.php and that is the same. No HTML outputted to the page, and no pdf gets generated.


RE: PDFs Have Suddenly Stopped Displaying - falkoner - 03-23-2017 05:20 AM

Do the Web server logs give any clue?

I assume you did nothing to your weberp installation over that period?

Tim


RE: PDFs Have Suddenly Stopped Displaying - sunshinelock - 03-23-2017 06:08 AM

I did nothing to my installation.

I just checked the error logs and don't see anything to indicate a problem within weberp or any flags on any other processes that may be related.


RE: PDFs Have Suddenly Stopped Displaying - sunshinelock - 03-27-2017 10:55 PM

No other help on this?


RE: PDFs Have Suddenly Stopped Displaying - TurboPT - 03-28-2017 07:30 AM

Well, shooting-in-the-dark, so to speak:

1. Try another browser, see same results ?
2. Clear browser cache, try again, same results ?
3. If possible, try after a reboot ?
4. etc...

Without others having similar trouble, we're relying upon you to help us troubleshoot, since we obviously cannot access your system.

On a side note:
"They tell me nothing has changed" can be suspicious if this was sudden. [for example, like this happened after a known weekend where "system maintenance" was scheduled to be done, and everything was fine before then]
I'm NOT saying that they're lying, but the dates/versions of certain system libraries from what they may have been previously can be possibly a clue -- assuming that you have a way to know when the last round of system updates may have been done, and what all was included in the update.


RE: PDFs Have Suddenly Stopped Displaying - sunshinelock - 03-29-2017 12:20 AM

I just upgraded my webERP to 4.13 minutes ago. I tried to print a customer invoice pdf and get this

TCPDF ERROR: Some data has already been output, can't send PDF file


RE: PDFs Have Suddenly Stopped Displaying - falkoner - 03-29-2017 01:26 AM

This means that some information has already been sent to the browser. Is there anything before this? If not try looking at the page source and see if there is some html hidden away there.

Tim


RE: PDFs Have Suddenly Stopped Displaying - sunshinelock - 03-29-2017 02:23 AM

View page source:


<strong>TCPDF ERROR: </strong>Some data has already been output, can't send PDF file