webERP Forum
*** Serious vulnerability - Printable Version

+- webERP Forum (http://www.weberp.org/forum)
+-- Forum: webERP Discussion (/forumdisplay.php?fid=1)
+--- Forum: Problems / Bugs? (/forumdisplay.php?fid=8)
+--- Thread: *** Serious vulnerability (/showthread.php?tid=2113)

Pages: 1 2


RE: *** Serious vulnerability - Forums - 02-19-2014 10:30 PM

The macro _must_ authenticate or otherwise by definition the data is available for anybody to view.

Tim


RE: *** Serious vulnerability - icedlava - 02-19-2014 10:38 PM

(02-19-2014 10:30 PM)Forums Wrote:  The macro _must_ authenticate or otherwise by definition the data is available for anybody to view.

Tim
That's correct, but there are other ways to feed the macro most likely.

Is there any vulnerability reporting and fix process for webERP? I think it could be useful to have even though the use might occur rarely. Might help so we don't feed anyone that might be bored enough to want to go play with their new found knowledge.


RE: *** Serious vulnerability - Forums - 02-19-2014 11:22 PM

Agreed


RE: *** Serious vulnerability - icedlava - 02-19-2014 11:27 PM

More generally, and as per my prior post in this thread, this highlighted to me some other possible issues so I'll be looking at session.inc and ConnectDB especially in reference to the $_SESSION['DatabaseName'] and how it is used in the code, more generally. I think it is worth a review.


RE: *** Serious vulnerability - jo lwebuga - 02-20-2014 02:35 AM

Thank you Tim and Icedlava for the warning


RE: *** Serious vulnerability - phil - 02-20-2014 01:00 PM

Sorry my bad ... should be using the API for this function - I need to send an advice to the mailing list too.