webERP Forum

Full Version: PHP error without warning when logging is enabled - SOLVED
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
I am still on the master branch (I was only asking if I should switch to the bug fixes branch, I will continue to follow the master branch).

I am confused why you recommend changing log severity level back to none. I thought the error was due to my not having a valid log file path in Setup => System Parameters => Path to log files. Do you think the fwrite will fail again if revert your change? (I am assuming the missing field data in the log is a seperate issue)
Only recommended to avoid errors if you revert the change.

Feel free to keep the change as-is, if desired, though what is being logged is not very useful.

I'll add another comment to this thread after the commit is merged this weekend.
Understood, thanks! :-) (I temporarily reverted the change just to prove to myself the fault still existed even with a valid file path configured).

I also updated the post title to remove SOLVED, which was premature of me (I was thinking the issue was only my enabling logging without configuring a valid log file path).
The fix has been committed, so you should be able to pull the change. I also fixed a typo in one of the log severity options, so there will be a couple of files plus the related changelog updates.

Here's example logging testing the fix with various log levels set:
2022-05-14 08-05-32,SUCCESS Report,admin,System configuration updated
2022-05-14 08-05-55,INFORMATION Message,admin,System configuration updated
2022-05-14 08-05-05,SUCCESS Report,admin,System configuration updated
2022-05-14 08-05-37,SUCCESS Report,admin,System configuration updated
2022-05-14 08-05-22,SUCCESS Report,admin,System configuration updated
2022-05-15 04-05-52,ERROR Report,admin,The unit of measure can not be created because another with the same name already exists.
2022-05-15 04-05-31,WARNING Report,admin,The the system is in demo mode and the security model administration is disabled
2022-05-15 04-05-16,INFORMATION Message,admin,The system is not configured for picking lists. A configuration parameter is required where picking slips are required. Please consult your system administrator.

Thanks for reporting the issue!
Thanks @TurbuPT! I pulled from master and found no issues in basic testing.
Thanks for the update!
Pages: 1 2