webERP Forum

Full Version: UpgradeDatabase.php does not do anything
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi,

I'm using SVN latest code and when I login to webERP, I got this message

"INFORMATION Message : This script will perform any modifications to the database required to allow the additional functionality in later scripts.
The webERP code is version 4.07.1 and the database version is 4.07.0
Click to do a database backup now before proceeding!"

There are a few problems I'd like to ask:
1) When I click to do database backup, it does not seem to do anything: just open a new window and display the same screen as above.
2) When I click the "Perform Database Upgrade" button, there is no error just display the following:

"INFORMATION Message : If there are any failures then please check with your system administrator. Please read all notes carefully to ensure they are expected"

and when I logout & login again, the first screen above to upgrade the database shows up again....

Does anyone have this problem?

I check UpgradeDatabase.php and line 138 have a blank in the case of '4.07.0', is it causing the problem?

$SQLScripts[] = './sql/mysql/upgrade4.05-4.06.sql';
case '4.06.6':
$SQLScripts[] = './sql/mysql/upgrade4.06-4.07.sql';
case '4.06.7':
$SQLScripts[] = './sql/mysql/upgrade4.07-4.08.sql';
case '4.07.0':
break;
} //end switch


What I did is I run manually this sql/mysql/upgrade4.07-4.08.sql script
and it worked well...

Just reporting this issue, and I'm wondering if I just run that single script is enought the same action?

Thanks,
Thomas

Hi Tim,

The Upgrade button is fine now...

but the "Click to do a database backup now before proceeding!"
is still not doing anything

Thanks,
thanks Thomas I fixed it durinng my review yesterday.
You just nneded to add the new SQL script in the switch statement