webERP Forum

Full Version: GetText Not Working With GIT Version
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I have our production 4.14.1 and GIT versions running on the same server.

Files messages.po and update just fine in both versions when managing language via Z_poAdmin.php. However, nothing ever changes with the GIT version.

Any ideas are greatly appreciated...
As soon as I set my user language to English (clicked the MODIFY button with no other changes) it started working.

Any thoughts on this?
FYI I tried another user and had the same issue. Now that I have reset the user language for one user GetText is working for both users.
Something to do with this?

PHP Code:
        $_SESSION['PDFLanguage'] = $_POST['PDFLanguage'];
'includes/LanguageSetup.php');// After last changes in LanguageSetup.php, is it required to update? 

And... GIT version looks great. I have been doing extensive testing and you guys gave done a bunch of work!

Greatly appreciated!!!
Still having trouble with this. Files are saved and updated but nothing is changing with GIT version...
Tried both Firefox and Opera and same results.

Never have any trouble with 4.14.1 on the same server.
Hmm, I am using the latest code from Git and have just switched the language between English and German with no problem. This would imply it is a server set up thing. Are you saying that with the old code you can switch between languages fine, but just not with the new code?

Also is this using the .mo files from Git or ones you generated yourself?

Have both versions running on the same server.

4.14.1 production and GIT -- Zero issues with 4.14.1 but GIT gives me very strange behavior. For example as I navigate menus the top menu captions may change from page to page. Even a forced refresh CTL+F5 has no impact.

Opera and Firefox yield same strange results...
Switching languages with GIT version seems to work fine but changes to language files (i.e., "Maintain Language Files") acts very odd...
Could it be related to this?
I will try another instance on another server Monday...
Could this be some sort of session-related thing due to two instances?