webERP Forum

Full Version: Upgrade to 4.15 from 4.14.1
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
I copied the new 4.15 under my htdocs, but when I run it, not all reports work.
For instance running the tax report give me the following error, which are not present in 4.14.1
running XAMPP under windows
Quote:The petty cash transaction details could not be retrieved because Table 'weberp.pcashdetailtaxes' doesn't exist
Back to the menu
SELECT supptrans.trandate, supptrans.type, systypes.typename, supptrans.transno, suppliers.suppname, supptrans.suppreference, supptrans.ovamount/supptrans.rate AS netamount, supptranstaxes.taxamount/supptrans.rate AS taxamt FROM supptrans INNER JOIN suppliers ON supptrans.supplierno=suppliers.supplierid INNER JOIN systypes ON supptrans.type=systypes.typeid INNER JOIN supptranstaxes ON = supptranstaxes.supptransid WHERE supptrans.trandate >= '2018-04-01' AND supptrans.trandate <= '2018-04-30' AND (supptrans.type=20 OR supptrans.type=21) AND supptranstaxes.taxauthid = '14' ORDER BY
You need to run the sql/mysql/upgrade4.14.1-4.15.sql script. It should have run automatically but it seems it hasn't.

Thank you Tim, that did the trick.

Ran the sql manually and then when I logged on again the system want to do a database upgrade, so ran it and now my version number on the footer are also correct.

Thanks again.

That was likely my 'goof' Tim.

Exson had pointed out that the version in file was not updated to 4.15 (from 4.14.1) in the release cut.
(there were two files in one of the 'release checklist' steps, which I evidently overlooked the first one mentioned, so I split that step into two)

So, I'm working on a 4.15.1 to include that, plus another install/index.php update that seems to rollback a portion of apmuthu's change from early April.

Also, I'm testing a clean-install, and using the installer, I'm having trouble understanding why only 80 tables to the weberp database are written, but the rest are not. This has been repeated several times. As the installer continues, all 157 tables to the weberpdemo DB do get installed every time.

Even though SET FOREIGN_KEY_CHECKS = 0; is in the script, the tables that have FOREIGN KEY entries are the ones that are NOT created. However, if I run that same default.sql script at the command line (not using the installer), everything gets created as expected.

There are no errors in the apache or mysql logs as the installer runs, so I'm not sure what is going on here, any ideas?
I have MariaDB 10.0.34
Yeah I have come across this before. It has to do with the fact that the PHP mysql drivers seem to reset the foreign key driver settings, though I don't know why.

To cure it put the following lines at line 1215 of install/index.php (just inside the for loop:

$FK_Result = mysqli_query($db,$FK_SQL);

and it seems to work.

Thanks for that Tim.

I'm about to give that a try, though I'll add a small change to cover mysql as well as mysqli with the query.
That worked with the first attempt, Tim, thanks.

I applied that handling (as part of a couple of other minor changes) near the end of this branch commit.
I installed with Ap Muthu's correction being in, and it all seemed to work fine, why is it being taken out?

The mysql extension has been deprecated for years, and hasn't been maintained for a very long time. Mysqli works as from mysql version 4.1 released in 2004, so should we be supporting an extension that is potentially insecure and buggy? If anybody is using a version of mysql that is 15 years old they should upgrade Smile

I agree on the MySQLi...

The other change, was apparently needed based on findings with install issues with 4.15. See merge #62 that Exson committed, as it was a couple of very minor things.
I installed fine with my change, and I haven't pulled in Exson's change because having read your comments on the commit I wasn't convinced about it.
Pages: 1 2