webERP Forum

Full Version: Clean Installation (no demo data) Giving Unexpected Results
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello everyone,

I've evaluated WebERP with all of the dummy data and decided that I like the project and wish to use it.

Obviously it would be nice to start with a clean slate, so it seemed like the easiest thing to do was to try to delete the dummy data manually as a web user (admin). After trying to remove customers, vendors, p.o.'s and the like, it quickly became obvious that the web of interdependencies between all of these items was too thick. I'm not complaining about that, it means that they are all actually interdependent which is totally how they should be. It *should* be very difficult to remove all of this type of stuff in a normal business environment.

So the next logical step would be to start with a fresh installation and just *not* load the dummy data. To test this, I first made sure to log out (important). Next, using phpMyAdmin I dropped all of the tables in the weberp database. Then I removed the config.php script from the installation directory. This essentially sets me back to square one.

After firing up the web browser and initiating the installation process anew, I made sure to uncheck the "Install the Demo Data" checkbox and proceeded with the installation. This does not seem to result in the same database schema as when we install the demo data. As a result, much functionality doesn't seem to be working.

Am I missing something? Is there a better way to start from a clean slate?

Thanks!
There is a problem with the installer which I fixed in this thread here http://www.weberp.org/forum/showthread.php?tid=8167
As I have said elsewhere it would be really good to get a release out containing this fix.
Downloading the latest github code should work just fine while we are waiting.
Excellent, there were two solutions proposed in that thread, manually running a SQL script and updating install/index.php to turn off the foregin key checks. I chose to edit install/index.php and everything seems to have worked. Thanks!
Yes the change to install/index.php is the best way
Reference URL's