webERP Forum

Full Version: Stock gets added instead of removed
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
So about two weeks ago we had stock taking in our company. Now our accountant went to
Items -> Inventory Items -> Quantity Adjustment
to remove a stock item that was not in the workshop anymore.
However, another item gets added (without any further information like serial number of course, just a dummy item) instead of the wanted one removed. That happened more than five times until we gave up. Adding items works just normal.
Has anyone else experienced the same or even better has a solution/workaround to that?

We are using the newest version of weberp.
I am using 4.14.1 and I just adjusted quantity of a controlled item by removing several and it worked fine.

I then went back and deleted all that remained and that also worked as expected.
I believe that there is a little confusion perhaps?

The quantity adjustment cannot be used to add/remove stock items, as there is no handling with the capability to do so within the script.

From solteccc's registration email:
Quote:Second question (for which I wanted to sign up on the forum): When we wanted to remove item from the stock list last week, instead of being removed, items were added onto the list. Without a serial number or any other information as of course none of that was added. As we had added about seven item we actually wanted to delete, we gave up. We are using the newest version of weberp. Do you have any idea what the reason for that could be? which I responded with:
Quote:Based on the issue that was mentioned, was this from the Stocks.php script? (The "Item Maintenance" screen?)

If so, were the left/right red navigation buttons used during the process?
There is some mishandling with those buttons causing strange behavior in the current script.
There is a fix applied to that handling for the next release. (which should be coming soon)

For the item that you want to remove: use the "Modify Item Details" option, use delete at the bottom, but avoid any left/right navigation button use.
The item should be removed as expected.
Do the same for the other items to remove.

Please try that handling, and report any issues to the "Problems / Bugs" forum.
Ah... So we are trying to DELETE a Stock Item, not reduce its quantity to zero.

Delete has always worked fine for me as well...
As I am not the one actually working with the accounting system, I cannot tell what the difference between remove and delete is.

What we want to do (in very non-expert words): There is a list of one type of stock items, pumps, with initially three pumps listed with their respective serial numbers, lets say the list looked like this:
pump 1: 123456
pump 2: 123457
pump 3: 123458

Now the last pump with the number 123458 was not in stock anymore but still in the system, so we want to take it out of the system to get a list like:
pump 1: 123456
pump 2: 123457

But instead we got a list like:
pump 1: 123456
pump 2: 123457
pump 3: 123458
pump 4:
pump 5:
pump 6:
pump 7:

So now the list says there are seven (or even more) pumps in stock with half of them not having any serial number in the system although actually there are only two.

This has worked in the menu Items -> Inventory Items -> Quantity Adjustment before but started showing this weird behaviour only recently.
To us, "remove" and "delete" are the same.

Whomever may be working with this matter, we would need to know which area of the app that is being used, and which script (or screen area) that appears to be having issues.

Again, as I've mentioned before in post #3, Quantity Adjustments has NOTHING to do with the behavior that is described.

What has been described in post #5 has to do with new item (stock) entries.
Reference URL's