webERP Forum

Full Version: [SOLVED] Login problem
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Background:
weberp 4.12.3 installed on a local machine, with one db for one company

1 user is set up ('admin')

Problem:
after unsuccessful attempts to login got message:
"ERROR Message Report : Security settings have not been defined for your user account. Please advise your system administrator. It could also be that there is a session problem with your PHP web server"

What I did:
in phpmyadmin, unblocked user and set password.
Currently getting "incorrect password" message, unable to login.

What do I do to login to Weberp?
What else I tried:
1) Setting password in phpmyadmin - through direct editing of a field, and through console:
a) UPDATE www_users SET password=sha1('weberp') WHERE userid='admin'
b) UPDATE www_users SET password=sha1('d7226791a747c4de291a7d2a9ab6a8140aeb6170') WHERE userid='admin' (supposed to be a hashtagged version of 'weberp')
c) UPDATE www_users SET password=sha1('') WHERE userid='admin'
2) Created user admin1 with all the same values - and tryed a) b) c) to set new user's password

Nothing works: every time getting "incorrect password" message

Is there any other settings I am missing? How do I login to weberp?
Is there any error messages during the installation?
there was no error messages during installations. I used the system for about six months, when forgot the password, exceeded number of login attempts, and cannot login back now.
For each user:
fullaccess = 8
modulesallowed='1,1,1,1,1,1,1,1,1,1,1,'
Hi,
Tim has provided a solution here:

http://www.weberp.org/forum/showthread.p...swordReset

Hope it's helpful.

Best regards!

Exson
(11-15-2015 10:44 AM)Exsonqu_Qu Wrote: [ -> ]http://www.weberp.org/forum/showthread.p...swordReset

Thanks, I am afraid I am not getting it right...

1) Created a file password.php, and saved it in weberp folder
2) Is 'weberp' my database name?
3) http://localhost/weberp/password.php
4) Result:

Fatal error: Call to undefined function password_hash() in /Library/WebServer/Documents/weberp/password.php on line 4

What am I doing wrong?
OK, found the solution:
1) Update PHP to 5.5 or newer
Link for Mac OS X: http://php-osx.liip.ch/
2) Create php script - from Tim's post
3) The php file is to be saved in weberp folder
4) Run the file from browser - in my case: http://localhost/weberp/password.php
5) If script worked, you see a blanc page!
Special thanks to Exson for pointing the right solution!
Hi,
The password_hash() is only available from PHP 5.5.0.

The simple way is just change the password to '$2y$10$Q8HLC/2rQaB5NcCcK6V6ZOQG3chIsx16mKtZRoSaUsU9okMBDbUwG' in www_users table which userid is 'admin' by phpmyadmin or other tools.

Best regards!

Exson
It occurs when then password or email address typed by you has some typo or spelling errors. Delete the email address and type it again because may be due to spelling error Facebook has failed to detect it. Before entering passwords always make sure that caps lock is always turned off. As it is case-sensitive on entering passwords with on caps will be rejected Facebook, and you will be redirected back to the incorrect email address or password page again. For any Facebook login username and password related issue check this

Lowest Brokerage - 0.005%
Reference URL's