webERP Forum

Full Version: user settings possible bug
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
edit an existing user settings, change setting and update -> original password is overwritten to something else other than existing password.
every time there is a need to update the user settings for an individual, need to find their password and enter it before updating to make sure existing password is not overwritten.

Seems there have been alot of great security improvements in the last few editions with added privileges for different actions. But sometimes finding all the settings to allow users stock privileges, bank account privileges, etc can take a long time and can get missed. Any interest to move all these privilege settings under the user account setup so everything could be done at once when the new user joins the system?
Hi,
What version are you using now?
I have checked the trunk, there is no such problem for password overwritten.
Best regards!

Exson
hi Exson;
webERP version 4.12.3

I just tested again with different users to make sure I am not going crazy but same situation. When I update some of the settings, the current password is overwritten when some settings in the user account is changed and saved. Then I tested an account with a shorter password, it was not overwritten. So maybe this has something to do with the length of the password.
12 characters gets overwritten
6 characters does not
I am not sure what is causing this, but same situation on all passwords that are generated with 12 characters

tks for your attention.
I'm wondering whether this is a browser issue. What browser are you using? Have you tried it with different browsers?

Tim
Reference URL's