webERP Forum

Full Version: change the language will not work
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I use weberp on qnap-NAS. I will change the menue-language to german.
(in user-settings)

But it will not work.

I have it testet with the package-installation and the manual installation.

Exact the same function under http://www.weberp.org/weberp/index.php will work fine.

any idea?

best regards
Josef Schnieder
hi, Josef,

Does German locale installed in your system?

You can use locale -a command to check it.

Best regards!

Exson
hi Exson

I installed the de_DE locale on the qnap-NAS.
Now it works!

Thanks!!!!!!

best regards
Josef Schnieder
Hello together.

Itry the same with my settings. but nothing works.

I change the language in the settings,logout and nothing happens.

i looked for the german language pack and it is inside also.

what can i do else?

(10-07-2015 09:50 PM)ThoGa1977 Wrote: [ -> ]Hello together.

Itry the same with my settings. but nothing works.

I change the language in the settings,logout and nothing happens.

i looked for the german language pack and it is inside also.

what can i do else?

how can i check if my qnap has the german settings?
Hi,

It's an issue with OS instead of webERP application.

What you need to do is login the linux operating system and issue locale -a command at the terminal.

Best regards!

Exson
Hi again.
thx for first answers.

i login the linux operating system and issue the command at terminal.
German locale isnĀ“t installed in our system.

we use a qnap TVS-471U-RP.

now my question, how can i install German locale?
Issue the following commands:

locale-gen de_DE
locale-gen de_DE.UTF-8

You will need to restart the web server after this.

Tim
thx again for rush answer.

After i insert the command locale -a, the system written :
C
en_US.utf8

after i insert
locale-gen de_DE or locale-gen de_DE.UTF-8 the system written: -sh: locale-gen: command not found

what is wrong now?
Ok, try this command instead:

localedef -f UTF-8 -i de_DE de_DE.utf8

Thanks
Tim
Good morning Tim.

After using this command:
[~] # localedef -f UTF-8 -i de_DE de_DE.utf8

the system answers:
cannot open locale definition file `de_DE': No such file or directory

whats wrong now?
Reference URL's